Represents a curtain wall accessory element.
typedef struct { API_Elem_Head head; short pen; short filler_1; API_CWAccessoryCategoryID category; API_Guid owner; API_Guid symbolID; bool hasSymbol; bool flipped; bool filler_2[2]; Int32 libInd; API_Guid refFrame; } API_CWAccessoryType;
Members
- head
- General element header.
- pen
- For internal use.
- category
- Category of the accessory. See API_CWAccessoryCategoryID.
- owner
- Owner Curtain Wall.
- symbolID
- Object identifier.
- hasSymbol
- In normal case it is always true.
- flipped
- Curtain Wall Accessory is flipped?
- libInd
- Library Part index.
- refFrame
- Accessory is always joins to a frame. This is the reference frame.
Remarks
The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWJunctionCategoryID
API_CurtainWallType,
API_CWFrameType,
API_CWJunctionType,
API_CWPanelType,
API_CWSegmentType
API_Polygon,
API_Coord,
API_PolyArc,
API Types