API_​CWallComponent

Describes the simple fills contained in composite structures.

    typedef struct {
        API_AttributeIndex buildingMaterial;
        short              framePen;
        short              flagBits;
        double             fillThick;
    } API_CWallComponent;

 

Members

buildingMaterial
The index of the building material attribute.
fillPen
The index of the frame pen [0..255]. A negative index means the end face line is hidden.
flagBits
The component flags of the building material (see Remarks).
fillThick
The absolute thickness of the component in meters.

 

Remarks

The meaning of the flags in the flagBits field:

Value

Description

APICWallComp_Core

the composite skin is part of the core.

APICWallComp_Finish

The composite skin is part of the finish.

API 17 In Archicad 17 composite skins contain a building material index and skin priority is inside the building material.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Attributes.h

 

See Also

API_CompWallType, API_AttributeDef, API_AttributeIndex,
API Types