API_​CWallFrameType

Represents a curtain wall frame element.

    typedef struct {
        API_Elem_Head             head;
        char                      filler_1[16];
        short                     pen;
        short                     material;
        GS::Bool8                 useOwnMaterial;
        GS::Bool8                 filler_2[3];
        double                    d;
        double                    w;
        double                    a1;
        double                    a2;
        double                    b1;
        double                    b2;
        double                    angle;
        API_CWFrameObjectType     objectType;
        API_CWFrameCategory       category;
        unsigned short            connPriority;
        GS::Bool8                 filler_3[6];
        API_Guid                  owner;
        API_Guid                  tag;
        GS::Bool8                 hasTag;
        GS::Bool8                 filler_4[7];
        API_Coord3D               begC;
        API_Coord3D               endC;
        API_Coord3D               orientation;
        UInt32                    joinedCWFramesBegCNum;
        UInt32                    joinedCWFramesEndCNum;
        UInt32                    assocCWPanelsNum;
        UInt32                    gridLineIDsNum;
        UInt32                    auxPanelDirsNum;
        Int32                     contourID;
    } API_CWallFrameType;

 

Members

head
General element header.
pen
For internal use.
material
Material index of the surface.
useOwnMaterial
Use own material or materials defined in the library part (in case of GDL based frame)?
d
Panel connection hole depth.
w
Panel connection hole width.
a1
Frame contour width inside. a1 and a2 are always equal and a1 + a2 = a on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
a2
Frame contour width outside. a1 and a2 are always equal and a1 + a2 = a on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
b1
Frame contour length inside. b1 = b - h on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
b2
Frame contour length outside. b2 = h on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
angle
Frame angle.
objectType
Type of the frame. See API_CWFrameObjectType.
category
Category of the frame. See API_CWFrameCategory.
connPriority
The priority of the frame in 3D intersections on a 1 to 19 scale.
owner
Owner Curtain Wall.
tag
Object identifier if the frame is GDL based.
hasTag
True if the frame is GDL based.
begC
First point of the frame’s reference line.
endC
Second point of the frame’s reference line.
orientation
Orientation of the frame. This vector is always perpendicular to the vector defined by begC and endC coordinates.
joinedCWFramesBegCNum
Number of frames joined at begC.
joinedCWFramesEndCNum
Number of frames joined at endC.
assocCWPanelsNum
Number of associated panels – one frame border two panels.
gridLineIDsNum
Number of identifier of the original GridMeshEdges in case of CoreFrame.
auxPanelDirsNum
Number of additional panel clamping vectors.
contourID
Contour ID for contour frames other has invalid value.

 

Remarks

The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWFrameAncestryType, API_CWFrameCategory, API_CWFrameObjectType
API_CurtainWallType, API_CWallAccessoryType, API_CWallJunctionType, API_CWallPanelType, API_CWallSegmentType
API_Guid, API_Coord3D, API_Elem_Head, API_Element, API_ElementMemo, API Types