API_​CWallJunctionType

Represents a curtain wall junction element.

    typedef struct {
        API_Elem_Head              head;
        char                       filler_1[16];
        short                      pen;
        short                      filler_2;
        API_CWJunctionCategory     category;
        API_Guid                   owner;
        API_Guid                   tag;
        GS::Bool8                  hasTag;
        GS::Bool8                  flipped;
        short                      filler_3[3];
        UInt32                     clampFramesNum;
        UInt32                     clampFrameOrientsNum;
        UInt32                     clampPanelsNum;
        UInt32                     filler_4;
    } API_CWallJunctionType;

 

Members

head
General element header.
pen
For internal use.
category
Category of the junction. See API_CWJunctionCategory.
owner
Owner Curtain Wall.
tag
Object identifier. (junction is always GDL based)
hasTag
In normal case it is always true.
flipped
Is flipped the frame?
clampFramesNum
Number of clamping frames.
clampFrameOrientsNum
In normal case it is equal to clampFramesNum
clampPanelsNum
Number of clamping panels.

 

Remarks

The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWJunctionCategory, API_CWJunctionClampFrameOrientation
API_CurtainWallType, API_CWallAccessoryType, API_CWallFrameType, API_CWallPanelType, API_CWallSegmentType
API_Polygon, API_Coord, API_PolyArc, API Types