Represents a curtain wall panel element.
typedef struct { API_Elem_Head head; char filler_1[16]; short pen; short outerSurfaceMaterial; short innerSurfaceMaterial; short cutSurfaceMaterial; GS::Bool8 useOwnMaterial; GS::Bool8 filler_2[7]; API_CWPanelObjectType objectType; API_CWPanelCategory category; double thickness; API_Guid owner; API_Guid tag; GS::Bool8 hasTag; GS::Bool8 hidden; short filler_3[3]; UInt32 edgesNum; UInt32 gridPolyIDsNum; } API_CWallPanelType;
Members
- head
- General element header.
- pen
- For internal use.
- outerSurfaceMaterial
- The material index of the exterior surface of the panel.
- innerSurfaceMaterial
- The material index of the interior surface of the panel.
- cutSurfaceMaterial
- The material index of the edge surface of the panel.
- useOwnMaterial
- Use own material or materials defined in the library part (in case of GDL based panel)?
- objectType
- Type of the panel. See API_CWPanelObjectType.
- category
- Category of the panel. See API_CWPanelCategory.
- thickness
- Thickness of the panel.
- owner
- Owner Curtain Wall.
- tag
- Object identifier if the panel is GDL based.
- hasTag
- True if the panel is GDL based.
- hidden
- Deleted panels remain in the database.
- edgesNum
- Number of neighbour frames.
- gridPolyIDsNum
- Reserved for internal use.
Remarks
The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWPanelCategory, API_CWPanelObjectType
API_CurtainWallType, API_CWallAccessoryType, API_CWallFrameType, API_CWallJunctionType, API_CWallSegmentType
API_Polygon, API_Coord, API_PolyArc, API Types