Represents a curtain wall segment element.
typedef struct { API_Elem_Head head; char filler_1[16]; short pen; short filler_2[3]; API_CWSpreadType spreadType; API_CWSegmentCategory category; double gridAngle; API_CWSegmentGridOrigPosType gridOriginPosition; UInt32 primaryPatternNum; UInt32 secondaryPatternNum; UInt32 panelPatternNum; API_Coord3D begC; API_Coord3D endC; API_Coord3D gridOrigin; API_Coord3D arcOrigin; GS::Bool8 negArc; GS::Bool8 filler_3[3]; API_CWSegmentType segmentType; API_Guid owner; API_Vector3D extrusion; UInt32 contourNum; UInt32 filler_4; } API_CWallSegmentType;
Members
- head
- General element header.
- pen
- The pen index.
- spreadType
- See API_CWSpreadType.
- category
- See API_CWSegmentCategory.
- extrusion
- The extrusion of the segment.
- gridAngle
- The angle of rows in relation to columns.
- gridOrigin
- The origin coordinate of the grid.
- gridOriginPosition
- See API_CWSegmentGridOrigPosType.
- primaryPatternNum
- The size of the primary pattern.
- secondaryPatternNum
- The size of the secondary pattern.
- panelPatternNum
- The size of the panel pattern.
- begC
- The begining coordinate of the segment.
- endC
- The end coordinate of the segment.
- arcOrigin
- The origin coordinate of the arc.
- negArc
- The arc of the segment is a negative (clockwise) arc.
- segmentType
- See API_CWSegmentType.
- owner
- Owner Curtain Wall.
- contourNum
- The size of the segment contour.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWSegmentCategory, API_CWSegmentGridOrigPosType, API_CWSegmentType, API_CWSpreadType
API_CurtainWallType, API_CWallAccessoryType, API_CWallFrameType, API_CWallJunctionType, API_CWallPanelType
API_Guid, API_Coord3D, API_Elem_Head, API_Element, API_ElementMemo, API Types