API_​CWBoundaryFramePosType

Define curtain wall boundary frame position.

    typedef enum {
        APICW_Boundary_Unknown,
        APICW_Boundary_OutSide,
        APICW_Boundary_Center,
        APICW_Boundary_Inside
    } API_CWBoundaryFramePosType;

 

Members

APICW_Boundary_Unknown
Unknown.
APICW_Boundary_OutSide
Boundary frames are on the outside of the grid.
APICW_Boundary_Center
Boundary frames are on the center of the grid.
APICW_Boundary_Inside
Boundary frames are on the inside of the grid.

 

Remarks

The API_CWBoundaryFramePosType type is used in the API_CWallSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWGridLineAssignType, API_CWPlacement_Type
API_CWSegmentType, API_CWSpreadType, API_CWSegmentCategory, API_CWSegmentGridOrigPosType
API_CWallSegmentType, API Types