API_​CWContourData

Represents a curtain wall contour type element.

    typedef struct {
        API_Polygon     polygon;
        API_Coord       **coords;
        Int32           **pends;
        API_PolyArc     **parcs;
        UInt32          **vertexIDs;
    } API_CWContourData;

 

Members

polygon
coords
pends
parcs
vertexIDs

 

Remarks

.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWSegmentType, API_CWSegmentCategoryID, API_CWSegmentGridOrigPosTypeID
API_CWSegmentType, API_CWFrameType, API_CWPanelType, API_CWJunctionType, API_CWAccessoryType, API_CurtainWallType
API_Polygon, API_Coord, API_PolyArc, API Types