API_​CWFrameAncestryType

Curtain wall frame ancestry type.

    typedef enum {
        APICWFaT_Unknown,
        APICWFaT_CoreFrame,
        APICWFaT_CustomFrame
    } API_CWFrameAncestryType;

 

Members

APICWFaT_Unknown
APICWFaT_CoreFrame
APICWFaT_CustomFrame

 

Remarks

The API_CWFrameAncestryType type is used in the API_CWFrameType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWFrameCategory, API_CWFrameObjectTypeID
API_CWFrameType, API Types