Available curtain wall frame categories.
typedef enum { APICWFrC_Primary, APICWFrC_Secondary, APICWFrC_Boundary, APICWFrC_Custom } API_CWFrameCategory;
Members
- APICWFrC_Primary
- Primary (vertical by default).
- APICWFrC_Secondary
- Secondary (horizontal by default).
- APICWFrC_Boundary
- Boundary.
- APICWFrC_Custom
- Custom (user has edited or created).
Remarks
The API_CWFrameCategory
type is used in the API_CWFrameType structure.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWFrameAncestryType, API_CWFrameObjectTypeID
API_CWFrameType, API Types