API_​CWFrameObjectType

Curtain wall frame object type.

    typedef enum {
        APICWFrObjectType_Invisible,
        APICWFrObjectType_Generic,
        APICWFrObjectType_ButtGlazed,
        APICWFrObjectType_GDL,
        APICWFrObjectType_InvisibleConnectedTurning,
        APICWFrObjectType_InvisibleConnectedStill
    } API_CWFrameObjectType;

 

Members

APICWFrObjectType_Invisible
APICWFrObjectType_Generic
APICWFrObjectType_ButtGlazed
APICWFrObjectType_GDL
APICWFrObjectType_InvisibleConnectedTurning
APICWFrObjectType_InvisibleConnectedStill

 

Remarks

The API_CWFrameObjectType type is used in the API_CWallFrameType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWFrameAncestryType, API_CWFrameCategory
API_CWallFrameType, API Types