Describes the different calculated values for curtain wall frames.
typedef struct { GS::uchar_t typeText[API_UniLongNameLen]; GS::uchar_t categoryText[API_UniLongNameLen]; double direction; double width; double depth; double length; API_AttributeIndex material; short position; short filler_1[13]; } API_CWFrameQuantity;
Members
- typeText
- Generic or the name of the GDL object in case of GDL based frame.
- categoryText
- Category of the frame in textual form. See API_CWFrameCategory for possible values.
- filler_1
- Reserved for later use.
- direction
- Direction of the frame.
- width
- Width of the frame.
- depth
- Depth of the frame
- length
- Length of the frame.
- material
- Material index of the frame.
- position
- Physical position of the frame. See API_CWFrameCategory for possible values.
- filler_2
- Reserved for later use.
Remarks
See also the curtain wall frame parameters for listing in Appendix A of the GDL Reference manual.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_AttributeIndex, ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types