API_​CWFrameType

Represents a Curtain Wall Frame element.

    typedef struct {
        API_Elem_Head               head;
        short                       pen;
        short                       filler_0;
        API_AttributeIndex          material;
        bool                        useOwnMaterial;
        bool                        filler_1[3];
        API_AttributeIndex          buildingMaterial;
        API_AttributeIndex          cutLineType;
        short                       cutLinePen;
        short                       filler_2;
        double                      d;
        double                      w;
        double                      a1;
        double                      a2;
        double                      b1;
        double                      b2;
        double                      angle;
        API_CWFrameObjectTypeID     objectType;
        unsigned short              connPriority;
        UInt32                      classID;
        API_Guid                    owner;
        API_Guid                    symbolID;
        bool                        hasSymbol;
        bool                        deleteFlag;
        bool                        defaultSubElem;
        bool                        filler_3;
        UInt32                      segmentID;
        API_GridElemID              cellID;
        API_Coord                   begRel;
        API_Coord                   endRel;
        API_Coord3D                 begC;
        API_Coord3D                 endC;
        API_Coord3D                 orientation;
        UInt32                      joinedCWFramesBegCNum;
        UInt32                      joinedCWFramesEndCNum;
        UInt32                      assocCWPanelsNum;
        Int32                       libInd;
        UInt32                      auxPanelDirsNum;
        Int32                       contourID;
        GS::uchar_t                 className[256];
    } API_CWFrameType;

 

Members

head
General element header.
pen
For internal use.
material
Material index of the surface.
useOwnMaterial
Use own material or materials defined in the library part (in case of GDL based frame)?
buildingMaterial Featuring API 22
Building Material of the frame.
cutLineType Featuring API 22
Line index of the cut part of the frame on the floorplan.
cutLinePen Featuring API 22
Pen index of the cut part of the frame on the floorplan.
d
Panel connection hole depth.
w
Panel connection hole width.
a1
Frame contour width inside. a1 and a2 are always equal and a1 + a2 = a on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
a2
Frame contour width outside. a1 and a2 are always equal and a1 + a2 = a on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
b1
Frame contour length inside. b1 = b - h on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
b2
Frame contour length outside. b2 = h on the Frame Type and Geometry tabpage of the Frame Settings Dialog.
angle
Frame angle.
objectType
Type of the frame. See API_CWFrameObjectTypeID.
connPriority
The priority of the frame in 3D intersections on a 1 to 19 scale.
classID New in API 22
Previously known as category.
owner
Owner Curtain Wall.
symbolID
Object identifier if the frame is GDL based.
hasSymbol
True if the frame is GDL based.
deleteFlag
Flags a frame class for deletion. In this case, the frame’s className should be the name of the class to substitute it with.
defaultSubElem New in API 22
Set as default sub-element.
segmentID New in API 22
Identifier of containing segment.
cellID New in API 22
Identifier of containing cell.
begRel New in API 22
Relative first point in cell.
endRel New in API 22
Relative second point in cell.
begC
First point of the frame’s reference line.
endC
Second point of the frame’s reference line.
orientation
Orientation of the frame. This vector is always perpendicular to the vector defined by begC and endC coordinates.
joinedCWFramesBegCNum
Number of frames joined at begC.
joinedCWFramesEndCNum
Number of frames joined at endC.
assocCWPanelsNum
Number of associated panels – one frame border two panels.
libInd
Object Library Part index if the frame is GDL based.
auxPanelDirsNum
Number of additional panel clamping vectors.
contourID
Contour ID for contour frames other has invalid value.
className
Name of the Frame class.

 

Remarks

The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.

API_GridElemID is a typedef for UInt64.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWFrameAncestryType, API_CWFrameCategory, API_CWFrameObjectTypeID
API_CurtainWallType, API_CWAccessoryType, API_CWJunctionType, API_CWPanelType, API_CWSegmentType
API_Guid, API_AttributeIndex, API_Coord3D, API_Elem_Head, API_Element, API_ElementMemo, API Types