API_​CWGridLineAssignType

Curtain wall grid line assign type.

    typedef enum {
        APICW_GridLine_Unknown,
        APICW_GridLine_Primary,
        APICW_GridLine_Secondary
    } API_CWGridLineAssignType;

 

Members

APICW_GridLine_Unknown
Unknown.
APICW_GridLine_Primary
Primary (vertical).
APICW_GridLine_Secondary
Secondary (horizontal).

 

Remarks

The API_CWGridLineAssignType type is used in the API_CWSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWBoundaryFramePosID, API_CWPlacement_Type
API_CWSegmentType, API_CWSegmentCategoryID, API_CWSegmentGridOrigPosTypeID
API_CWSegmentType, API Types