Curtain wall junction clamp frame orientation type.
typedef enum { APICWJunClampFrameOrient_NoClamp, APICWJunClampFrameOrient_ClampAtBeg, APICWJunClampFrameOrient_ClampAtEnd, APICWJunClampFrameOrient_ClampAtBothEnds } API_CWJunctionClampFrameOrientation;
Members
- APICWJunClampFrameOrient_NoClamp
- No clamp.
- APICWJunClampFrameOrient_ClampAtBeg
- Clamp at begin.
- APICWJunClampFrameOrient_ClampAtEnd
- Clamp at end.
- APICWJunClampFrameOrient_ClampAtBothEnds
- Clamp both at begin and at end.
Remarks
The API_CWJunctionClampFrameOrientation
type is used in the API_CWallJunctionType structure.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h