API_​CWJunctionQuantity

Describes the different calculated values for curtain wall junctions.

    typedef struct {
        GS::uchar_t     typeText[API_UniLongNameLen];
        double          filler[8];
    } API_CWJunctionQuantity;

 

Members

typeText
Junction is always GDL based. This is the name of the GDL object.
filler
Reserved for later use.

 

Remarks

See also the curtain wall junction parameters for listing in Appendix A of the GDL Reference manual.

API 21 removed those quantities (width, height, length) that were never calculated.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types