Represents a curtain wall junction element.
typedef struct { API_Elem_Head head; short pen; short filler_1; API_CWJunctionCategoryID category; API_Guid owner; API_Guid symbolID; bool hasSymbol; bool flipped; bool filler_2[6]; UInt32 clampFramesNum; UInt32 clampFrameOrientsNum; UInt32 clampPanelsNum; Int32 libInd; UInt32 filler_3; } API_CWJunctionType;
Members
- head
- General element header.
- pen
- For internal use.
- category
- Category of the junction. See API_CWJunctionCategoryID.
- owner
- Owner Curtain Wall.
- symbolID
- Object identifier. (junctions are always GDL based)
- hasSymbol
- In normal case it is always true.
- flipped
- True, if the frame is flipped.
- clampFramesNum
- Number of clamping frames.
- clampFrameOrientsNum
- In normal case it is equal to
clampFramesNum
- clampPanelsNum
- Number of clamping panels.
- libPartID
- Object Library Part index. (junctions are always GDL based)
Remarks
The Curtain Wall is a hierarchical (system) element consisting of Frame, Panel, Accessory and Junction components: these are the Members of the Curtain Wall, arranged on a Base Surface according to a pre-defined scheme.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWJunctionCategoryID,
API_CWJunctionClampFrameOrientationID
API_CurtainWallType,
API_CWAccessoryType,
API_CWFrameType,
API_CWPanelType,
API_CWSegmentType
API_Polygon,
API_Coord,
API_PolyArc,
API Types