API_​CWPanelQuantity

Describes the different calculated values for curtain wall panels.

    typedef struct {
        GS::uchar_t        typeText[API_UniLongNameLen];
        double             vertDirection;
        double             horDirection;
        double             thickness;
        double             surface;
        double             grossSurface;
        double             perimeter;
        double             grossPerimeter;
        API_AttributeIndex material_outer;
        API_AttributeIndex material_inner;
        API_AttributeIndex material_cut;
        short              function;
        short              filler_1;
        double             width;
        double             nominalWidth;
        double             height;
        double             nominalHeight;
        GS::uchar_t        orientationText[API_UniLongNameLen];
        double             filler[4];
    } API_CWPanelQuantity;

 

Members

typeText
Generic or the name of the GDL object in case of GDL based panel.
vertDirection
Vertical direction.
horDirection
Horizontal direction.
thickness
Thickness of the panel.
surface
Net surface of the panel. Equal to grossSurface minus the surface covered by neighbouring frames.
grossSurface
Gross Surface of the panel. Equal to surface plus the surface covered by neighbouring frames.
perimeter
Net perimeter of the frame.
grossPerimeter
Gross perimeter of the frame.
material_outer
Material index of the exterior surface of the panel.
material_inner
Material index of the edge of the panel.
material_cut
Material index of the interior surface of the panel.
function
Type of the panel. Possible values: 0 – fixed, 1 – door, 2 – window (value of AC_Panel_Type GDL parameter)
filler_1
Reserved for later use.
width
Width of the panel. (The visible part of the panel. It doesn’t includes the part covered by neighbouring frames.)
nominalWidth
Nominal panel width (it is equal to width if the panel is generic [non GDL based].)
height
Reserved for later use. (The visible part of the panel. It doesn’t includes the part covered by neighbouring frames.)
nominalHeight
Nominal panel height (it is equal to height if the panel is generic [non GDL based].)
filler
Reserved for later use.

 

Remarks

See also the curtain wall panel parameters for listing in Appendix A of the GDL Reference manual.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types