API_​CWSegmentGridLineAssignType

Curtain wall segment grid line assign type.

    typedef enum {
        APICWSeGridLine_Unknown,
        APICWSeGridLine_Primary,
        APICWSeGridLine_Secondary
    } API_CWSegmentGridLineAssignType;

 

Members

APICWSeGridLine_Unknown
APICWSeGridLine_Primary
APICWSeGridLine_Secondary

 

Remarks

The API_CWSegmentGridLineAssignType type is used in the API_CWSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWSegmentType, API_CWSegmentCategoryID, API_CWSegmentGridOrigPosTypeID, API_CWSegmentBoundaryFramePosType
API_CWSegmentType, API Types