API_​CWSegmentGridOrigPosType

Curtain wall segment grid origin pos type.

    typedef enum {
        APICWSeGridOrigin_Unknown,
        APICWSeGridOrigin_Custom,
        APICWSeGridOrigin_FrameCentered,
        APICWSeGridOrigin_PanelCentered,
        APICWSeGridOrigin_EndWithFrame,
        APICWSeGridOrigin_StartWithFrame
    } API_CWSegmentGridOrigPosType;

 

Members

APICWSeGridOrigin_Unknown
APICWSeGridOrigin_Custom
APICWSeGridOrigin_FrameCentered
APICWSeGridOrigin_PanelCentered
APICWSeGridOrigin_EndWithFrame
APICWSeGridOrigin_StartWithFrame

 

Remarks

The API_CWSegmentGridOrigPosType type is used in the API_CWallSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWSegmentType, API_CWSpreadType, API_CWSegmentCategory
API_CWallSegmentType, API Types