Curtain wall segment grid origin pos type.
typedef enum { APICWSeGridOrigin_StartWithPattern, APICWSeGridOrigin_StartFromCenter, APICWSeGridOrigin_AlignToCenter, APICWSeGridOrigin_EndWithPattern } API_CWSegmentGridOrigPosTypeID;
Members
- APICWSeGridOrigin_StartWithPattern
- Pattern placement starts from the beginning of the segment.
- APICWSeGridOrigin_StartFromCenter
- The pattern starts from the center of the segment, repeating both ways.
- APICWSeGridOrigin_AlignToCenter
- The pattern is aligned so that the center of the segment is the center of a pattern.
- APICWSeGridOrigin_EndWithPattern
- Pattern placement starts from the end of the segment.
Remarks
The API_CWSegmentGridOrigPosTypeID
type is used in the API_CWSegmentPatternData structure.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWSegmentPatternDataAPI_CWSegmentType, API Types