Represents a curtain wall segment cell.
typedef struct { API_CWCellCrossingFrameTypeID crossingFrameType; UInt32 leftPanelID; UInt32 rightPanelID; UInt32 leftFrameID; UInt32 bottomFrameID; UInt32 crossingFrameID; } API_CWSegmentPatternCellData;
Members
- crossingFrameType
-
Describes the type of the crossing frame in the cell.
APICWCFT_NoCrossingFrame
The cell does not have a crossing frame.
APICWCFT_FromBottomLeftToTopRight
The cell has a crossing frame from its bottom left to its top right.
APICWCFT_FromTopLeftToBottomRight
The cell has a crossing frame from its top left to its bottom right.
- leftPanelID
- Class index of the panel left of the cell.
- rightPanelID
- Class index of the panel right of the cell.
- leftFrameID
- Class index of the frame left of the cell.
- bottomFrameID
- Class index of the frame under the cell.
- crossingFrameID
- Class index of the frame crossing the cell.
Requirements
- Version: API 22.0 or later
- Header: APIdefs_Elements.h