Represents the horizontal (primary) or vertical (secondary) pattern of a Curtain Wall segment.
typedef struct { API_CWSegmentPatternLogicID logic; API_CWSegmentGridOrigPosTypeID gridOriginType; UInt32 nPattern; UInt32 filler_1; double *pattern; UInt32 *flexibleIDs; UInt32 nFlexibleIDs; UInt32 nDivisions; UInt32 infillPanelID; UInt32 endWithID; } API_CWSegmentPatternData;
Members
- logic
-
Describes how the pattern is stretched in segments.
APICWSePL_FixedSizes
The length of the pattern is given explicitly. This may result in incomplete patterns.
APICWSePL_BestDivision
The length of the pattern is stretched, so that the least amount of stretching is done.
APICWSePL_NumberOfDivisions
The length of the pattern is stretched, so that exactly
nDivisions
amount of patterns are placed. - gridOriginType
- Describes how the pattern is aligned in segments. See available value in the documentation of API_CWSegmentGridOrigPosTypeID enum.
- nPattern
- Amount of columns/rows in the pattern.
- pattern
- The distances of each columns/rows.
- flexibleIDs
- The indices of columns/rows that can be stretched. Only used in case of
APICWSePL_BestDivision
orAPICWSePL_NumberOfDivisions
logic. - nFlexibleIDs
- Amount of stretchable columns/rows. Only used in case of
APICWSePL_BestDivision
orAPICWSePL_NumberOfDivisions
logic. - nDivisions
- Amount of divisions. Only used in case of
APICWSePL_NumberOfDivisions
logic. - infillPanelID
- Class index of the panel, that fills the end of an incomplete pattern. Use
APICWInfillWithPartial
to fill with partial pattern. Only used in case ofAPICWSePL_FixedSizes
logic. - endWithID
- The index of the ending panel.
Requirements
- Version: API 22.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWSegmentCategoryID,
API_CWSegmentGridOrigPosTypeID,
API_CWSegmentType
API_CurtainWallType,
API_CWAccessoryType,
API_CWFrameType,
API_CWJunctionType,
API_CWPanelType
API_Guid,
API_Coord3D,
API_Elem_Head,
API_Element,
API_ElementMemo,
API Types