Represents a curtain wall segment element.
typedef struct { API_Elem_Head head; short pen; short filler_1; API_CWSegmentCategoryID category; double gridAngle; API_Coord3D begC; API_Coord3D endC; API_Coord3D gridOrigin; API_Coord3D arcOrigin; bool negArc; bool filler_2[3]; API_CWSegmentTypeID segmentType; API_Guid owner; API_Vector3D extrusion; UInt32 contourNum; UInt32 patternCellNum; } API_CWSegmentType;
Members
- head
- General element header.
- pen
- The pen index.
- category
- See API_CWSegmentCategoryID.
- extrusion
- The extrusion of the segment.
- gridAngle
- The angle of rows in relation to columns.
- begC
- The begining coordinate of the segment.
- endC
- The end coordinate of the segment.
- gridOrigin
- The origin coordinate of the grid.
- arcOrigin
- The origin coordinate of the arc.
- negArc
- The arc of the segment is a negative (clockwise) arc.
- segmentType
- See API_CWSegmentTypeID.
- owner
- Owner Curtain Wall.
- contourNum
- The size of the segment contour.
- patternCellNum
- The amount of cells in the Segment pattern.
Requirements
- Version: API 12.0 or later
- Header: APIdefs_Elements.h
See Also
API_CWSegmentCategoryID,
API_CWSegmentGridOrigPosTypeID,
API_CWSegmentTypeID
API_CurtainWallType,
API_CWAccessoryType,
API_CWFrameType,
API_CWJunctionType,
API_CWPanelType
API_Guid,
API_Coord3D,
API_Elem_Head,
API_Element,
API_ElementMemo,
API Types