API_​CWSpreadType

Curtain wall spread type.

    typedef enum {
        APICWSpT_Unknown,
        APICWSpT_Uniform,
        APICWSpT_StartAtStart,
        APICWSpT_StartAtMiddle,
        APICWSpT_MiddleAtMiddle,
        APICWSpT_EndAtEnd
    } API_CWSpreadType;

 

Members

APICWSpT_Unknown
APICWSpT_Uniform
APICWSpT_StartAtStart
APICWSpT_StartAtMiddle
APICWSpT_MiddleAtMiddle
APICWSpT_EndAtEnd

 

Remarks

The API_CWSpreadType type is used in the API_CWSegmentType structure.

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Elements.h

 

See Also

API_CWSegmentType, API_CWSegmentCategory, API_CWSegmentGridOrigPosTypeID
API_CWSegmentType, API Types