Describes a daily profile usage contained in Operation Profile.
typedef struct { short startMonth; short startDay; short endMonth; short endDay; short recurrence; short dailyProfileIndex; } API_DailyProfileUsage;
Members
- startMonth
- Start month of the usage.
- startDay
- Start day of the usage.
- endMonth
- End month of the usage.
- endDay
- End day of the usage.
- recurrence
- Weekly recurrence of the usage. The
[1, 2, 4, 8, 10, 20, 40]
values correspond to Mon, Tue, Wed, Thu, Fri, Sat, Sun. All of these values can be combined so the max. value is 127. - dailyProfileIndex
- Index of the Daily Profile.
Requirements
- Version: API 16 or later
- Header: APIdefs_Attributes.h
See Also
API_OperationProfileType, API_AttributeDefExtAPI Types