API_​DescriptorRefType

The descriptor reference record.

    typedef struct {
        Int32     libIndex;
        Int32     setIndex;
        Int32     index;
        Int32     status;
        Int32     filler_3[8];
    } API_DescriptorRefType;

 

Members

libIndex
Index of the library part, place of the descriptor declaring
setIndex
Index of the listing database set, if status equals APIDBRef_Normal.
index
This member depends on the status field. If status equals APIDBRef _Normal, then index is index of the descriptor in the set, if status equals APIDBRef _Local, then index is index of the descriptor in the library part.
status
This member is status of descriptor(APIDBRef__Normal, APIDBRef__Local, APIDBRef_Deleted).
filler_3[8]
Reserved for later use

 

Remarks

This structure is used when you want to get the descriptors of an element. These descriptors are in the property objects of the element. See the ACAPI_Element_GetDescriptors function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API Types