API_​DescriptorType

Description of a descriptor.

    typedef struct {
        API_ListData_Head     head;
        char                  code[API_DBCodeLen];
        char                  keycode[API_DBCodeLen];
        char                  dbSetName[API_DBCodeLen];
        char                  **name;
        Int32                 filler_1[9];
    } API_DescriptorType;

 

Members

head
Contains the header information, including type, set index and index.
code
code string
keycode
key code string
dbSetName
the name of the database set; important when the descriptor is not found in the active databases, because you can still find out which database it came from
name
name of the descriptor

 

Remarks

This stucture is used when you get or search a descriptor in the listing database. See the ACAPI_ListData_Get, ACAPI_ListData_GetLocal and ACAPI_ListData_Search functions.

Don’t forget to dispose the name handle when you are done.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_ListData.h

 

See Also

API_ListData_Head, API_ListData,
Listing Manager, API Types