API_​DetailType

Represents a detail/worksheet (detail/worksheet mark).

    typedef struct {
        API_Elem_Head              head;
        short                      pen;
        short                      filler_1;
        API_AttributeIndex         ltypeInd;
        API_Coord                  pos;
        double                     angle;
        API_Guid                   markId;
        Int32                      filler_2;
        GS::uchar_t                detailName [API_UniLongNameLen];
        GS::uchar_t                detailIdStr [API_UniLongNameLen];
        bool                       horizontalMarker;
        bool                       windOpened;
        bool                       constructionElementsOnly;
        bool                       filler_3[5];
        API_DatabaseUnId           databaseID;
        Int32                      filler_4[8];
        API_Polygon                poly;
        API_MarkerLinkDataType     linkData;
        Int32                      filler_5[8];
    } API_DetailType, API_WorksheetType;

 

Members

head
General element header.
pen
Pen attribute index.
ltypeInd
Line type attribute index.
pos
Coordinate of the marker symbol. (See remarks)
angle
The rotation angle (radian) of the marker symbol.
markId 17
Guid of the marker symbol.
detailName Featuring API 11
Name of the detail/worksheet (Unicode string, UTF-8 encoding).
detailIdStr Featuring API 11
Reference ID of the detail/worksheet (Unicode string, UTF-8 encoding). If the text contains a ‘/’ character, then the text is split between the beginning and end marks.
horizontalMarker
Marker symbol is always horizontal?
windOpened
Side (detail/worksheet) window is opened?
constructionElementsOnly Featuring API 23
Copy construction elements only
databaseID
Database ID to switch to (see API_DatabaseUnId).
poly
The polygon of the detail/worksheet.

 

Remarks

Refer to the APIDb_ChangeCurrentDatabaseID function to access and operate on the corresponding Detail/Worksheet database. For detail related memo data see the ACAPI_Element_GetMemo function.

Note that the origin of the coordinate system of a detail/worksheet database corresponds to the reference point location of the detail/worksheet element on the floor plan, thus elements on the detail/worksheet databases are offseted by pos from their original location on the floor plan.
If the referencing detail/worksheet element was placed on a section/elevation window, then the y coordinate on the detail/worksheet database equals to the y value of the section database in order to help working with the vertical (elevation) level. In this case the pos.y data is ignored.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

API_AttributeIndex, API_Element, API_Elem_Head, API_Coord
APIDb_ChangeCurrentDatabaseID, APIDb_GetDetailDatabasesID, APIDb_GetWorksheetDatabasesID, APIDb_DeleteDatabaseID
ACAPI_Element_CreateExt, ACAPI_Element_ChangeExt
ACAPI_Element_GetDefaultsExt, ACAPI_Element_ChangeDefaultsExt
Element Manager, API Types