API_​DimBase

Describes the base element for dimensioning.

    typedef struct {
        API_Base        base;
        API_Coord       loc;
        API_Coord3D     loc3D;
    } API_DimBase;

 

Members

base
The base element.
loc
Location of the dimension line.
loc3D Changed in API 12
Coordinate of the base point in 3D (see API_Coord3D).

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Neig, API_Coord, API_DimensionType, API_RadialDimensionType, API_LevelDimensionType, API_AngleDimensionType, API_DimElem, API Types