API_​DimElem

Describes a dimension element.

    typedef struct {
        API_DimBase       base;
        API_NoteType      note;
        double            witnessVal;
        API_WitnessID     witnessForm;
        bool              fixedPos;
        bool              filler_1;
        short             filler_2;
        API_Coord         pos;
        double            dimVal;
        API_Coord3D       pos3D;
        Int32             filler_3[6];
    } API_DimElem;

 

Members

base
The dimensioned point.
note
Parameters of the dimension text.
witnessVal
Gap (APIWtn_Fix) or length (APIWtn_Large) of witness line according to witnessForm.
witnessForm
Witness line format (see API_WitnessID).
fixedPos
Fixed position (pos needed for calculation in this case only)
dimVal
Distance from previous DimElem (output only).
pos3D Changed in API 12
Corresponding coordinate on the dimension line in 3D.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_DimBase, API_NoteType, API_WitnessID, API_Coord, API_Coord3D, API Types