The representation of the Project Preferences / Dimensions tab page.
typedef struct { API_LengthDimFormat linear; API_AngleDimFormat angle; API_LengthDimFormat radial; API_LengthDimFormat level; API_LengthDimFormat elevation; API_LengthDimFormat doorwindow; API_LengthDimFormat parapet; API_AreaDimFormat area; short index; short filler_0; Int32 filler_1[3]; } API_DimensionPrefs;
Members
- linear
- Linear Dimensions preferences
- angle
- Angular Dimensions preferences
- radial
- Radial Dimensions preferences
- level
- Level Dimensions preferences
- elevation
- Elevation Dimensions preferences
- doorwindow
- Door, Window and Skylight Dimensions preferences
- parapet
- Sill Height Dimensions preferences
- area
- Area Calculations preferences
- index
- dimension style attribute index if the dimension prefs is stored for views (see API_DimensionAttrType)
Remarks
This structure is used by the APIEnv_GetPreferencesID function to get the settings of the Project Preferences / Dimensions page.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h