API_​DimLayoutID

Describes the layouting algorithm of the dimension.

    typedef enum {
        API_Legacy      = 0,
        API_Flexible,
        API_Centered,
        API_LayoutOff
    } API_DimLayoutID;

 

Members

API_Legacy
Legacy layouting algorithm. Layouting as in ArhiCAD 18 or before.
API_Flexible
Flexible layouting algorithm.
API_Centered
Centered layouting algorithm.
API_LayoutOff
Layouting logic turned off, all notes are placed on the center of their dimension unit without any collision detection.

 

Requirements

Version: API 19 or later
Header: APIdefs_Elements.h

 

See Also

API_DimensionType, API Types