Defines various orientations for dimension and label texts.
typedef enum { APIDir_Parallel, APIDir_Horizontal, APIDir_Vertical, APIDir_General, APIDir_Radial, APIDir_ArcDim, APIDir_Perpendicular } API_DirID;
Members
- APIDir_Parallel
- Parallel with element.
- APIDir_Horizontal
- Horizontal orientation.
- APIDir_Vertical
- Vertical orientation.
- APIDir_General
- General orientation.
- APIDir_Radial
- Radial orientation for radial dimensions.
- APIDir_ArcDim
- Special orientation for arc dimensions.
- APIDir_Perpendicular
- Perpendicular orientation for labels.
Requirements
- Version: API 22 or later
- Header: APIdefs_Elements.h
See Also
API_LabelType, API_DimensionType, API_RadialDimensionType, API_LevelDimensionType, API_AngleDimensionType, API Types