Default settings of 3D document.
typedef struct { API_UniformAttributeOptions attributeOptions; GS::uchar_t name[API_UniLongNameLen]; GS::uchar_t refId[API_UniLongNameLen]; bool vect3DHatching; bool vectSunShadow; bool mustBeTransparent; bool filler_1; API_CutPlanePlanConn intPlanConn; bool materialFrom3D; bool contureOff; API_AttributeIndex cMater; API_SkeletonOptions skeletonOptions; API_BoundaryDisplay boundaryDisplay; short boundaryPen; API_AttributeIndex boundaryLineType; short filler_2[3]; } API_DocumentFrom3DDefaults;
Members
- attributeOptions
- General representation of a Model Dispaly.
- name[API_UniLongNameLen]
- Name of the 3D document database (Unicode string, UTF-8 encoding).
- refId[API_UniLongNameLen]
- Reference ID of the 3D document database (Unicode string, UTF-8 encoding).
- vect3DHatching
- Vectorial 3D hatching option
- vectSunShadow
- Vectorial sun shadow generation options.
- mustBeTransparent
- Transparent effect (see-through Materials e.g. glass).
- intPlanConn
- Intended plan connectivity. It could be different from the state of its window.
- materialFrom3D
- Use Material Defined in 3D Cutting Planes.
- contureOff
- Vectorial sun shadow contour on(off).
- cMater
- Cut surface material.
- skeletonOptions
- Skeleton drawing options.
- boundaryDisplay
- Boundary display options
- boundaryPen
- Boundary pen (in case of overridden contours)
- boundaryLineType
- Boundary line type (in case of overridden contours)
Remarks
You are able to get and change the default settings of 3D document via APIEnv_GetDocumentFrom3DDefaultsID and APIEnv_ChangeDocumentFrom3DDefaultsID functions.
Requirements
- Version: API 12 or later
- Header: APIdefs_Environment.h
See Also
API_UniformAttributeOptions
API_AttributeIndex
API_CutPlanePlanConn
API Types
API_SkeletonOptions
API_BoundaryDisplay