Represents a 3D Document.
typedef struct { API_3DFilterAndCutSettings filterAndCutSettings; API_3DCutPlanesInfo cutSetting; bool cutaway3D; bool filler_1[7]; API_3DProjectionInfo projectionSetting; API_Coord floorPlanRotationOrigo; API_3DWindowInfo window3DInfo; API_AttributeIndex hiddenLineType; short hiddenLineLen; short effects3D; short filler_2; API_Rect drawRect; API_UniformAttributeOptions attributeOptions; API_CutPlanePlanConn currPlanConn; API_CutPlanePlanConn intPlanConn; short filler_3; bool materialFrom3D; API_DocumentSourceID docSrc; API_SkeletonOptions skeletonOptions; API_BoundaryDisplay boundaryDisplay; short boundaryPen; API_AttributeIndex boundaryLineType; bool filler_4[4]; bool transparency; } API_DocumentFrom3DType;
Members
- filterAndCutSettings
- Tells which elements should appear in the 3D document window. Corresponds to the Filter and Cut Settings dialog.
- cutSetting
- List of cut planes to apply
- cutaway3D
- Apply 3D cut away
- projectionSetting
- Projection settings (camera position etc.)
- floorPlanRotationOrigo
- 2D floorplan origo offset (only in skeleton drawing).
- window3DInfo
- Appearance settings of the 3D window
- hiddenLineType
- Linetype index for hidden lines
- hiddenLineLen
- effects3D
- Effects to apply
- drawRect
- Rect
- attributeOptions
- List of uniform attributes if attributeOptions.shouldUseUniformCutAttributes is set
- currPlanConn
- Current Plan connectivity
- intPlanConn
- Intended Plan connectivity
- materialFrom3D
- Use materials from the 3D window
- docSrc
- 3D Document source.
- skeletonOptions
- Skeleton drawing options
- boundaryDisplay
- Boundary display options
- boundaryPen
- Boundary pen (in case of overridden contours)
- boundaryLineType
- Boundary line type (in case of overridden contours)
- transparency
- Enable transparent surfaces in 3D window
Remarks
This structure is used by the APIEnv_GetDocumentFrom3DSettingsID and the APIEnv_ChangeDocumentFrom3DSettingsID environment functions.
Requirements
- Version: API 12 or later
- Header: APIdefs_Environment.h
See Also
API_Rect
API_AttributeIndex
API_3DFilterAndCutSettings
API_3DCutPlanesInfo
API_3DProjectionInfo
API_3DWindowInfo
API_UniformAttributeOptions
API_CutPlanePlanConn
API Types
API_SkeletonOptions
API_BoundaryDisplay