API_​DrawingLinkInfo

Parameters of a drawing link.

    typedef struct {
        API_DrawingLinkTypeID     linkTypeID;
        API_IDFTypeID             idfTypeID;
        API_Guid                  linkGuid;
        IO::Location              *linkPath;
        Int32                     filler_2;
        char                      name[256];
        char                      number[256];
        API_ViewNodeTypeID        viewType;
        bool                      viewDeleted;
        char                      filler_3[3];
        GSPtr                     viewPath;
        API_DrawingLinkTypeID     infoTypeID;
        Int32                     filler_4[2];
    } API_DrawingLinkInfo;

 

Members

linkTypeID
Type of the link
idfTypeID New in API 12
Type of the content; can be Drawing, Image, PDF, or undefined
linkGuid Changed in API 11
GUID for internal or external views
linkPath
The location of the file associated to the link in case of internal and external views, images, PDF type or API add-on file types
name
The name of the drawing
number
The number of the drawing
viewType
The type of the model behind the view (in case of view type links only)
viewDeleted
The destination view is not available (in case of view type links only)
viewPath
Pointer to a dynamically allocated C string containing the path to the source view in the Project Navigator in case of view type links (e.g. “\Untitled\0. Ground Floor”)
infoTypeID
The original type of the link if it is broken (used only when linkTypeID is API_DrawingLink_InfoID)

 

Remarks

You can get information about a given drawing link using this structure with the APIDb_GetDrawingLinkID function.

The linkPath location is used only for links having associated source file location, otherwise this pointer is nullptr.

The viewPath is filled out only for internal and external view type links, otherwise it is nullptr.

If the link has been broken then the linkTypeID parameter is API_DrawingLink_InfoID. In this case the infoTypeID field shows the original type of the link.

 

Requirements

Version: API 10 or later
Header: APIdefs_Database.h

 

See Also

API_DrawingLinkTypeID
API_ViewNodeTypeID
APIDb_GetDrawingLinkID
API Types