Specifies the drawing’s title object.
typedef struct { Int32 libInd; API_TitlePreviewModes previewMode; bool useUniformTextFormat; bool filler_0; short font; unsigned short faceBits; short textPen; double textSize; bool flipped; bool useUniformSymbolPens; short pen; API_Guid guid; Int32 filler_1[2]; } API_DrawingTitle;
Members
- libInd
- Library part index of the title.
- previewMode
- Show the title preview with or without the drawing itself (see API_TitlePreviewModes).
- useUniformTextFormat
- Use the fonts and style set on the title tabpage.
- font
- Title common text font ID.
- faceBits
- Plain, bold, italic, underline.
- textPen
- Title common text pen.
- textSize
- Title text size.
- flipped
- The title object is flipped.
- useUniformSymbolPens
- Use the pens set on the title tabpage.
- pen
- Title common pen.
- guid
- Guid of title element (the placed object).
Remarks
Drawing titles are now object based elements from Archicad 10.
Requirements
- Version: API 10 or later
- Header: APIdefs_Elements.h