Determines the type of the roof or slab edge trim.
In previous API versions this enum type used to be called API_RsideID
.
typedef enum { APIEdgeTrim_Vertical, APIEdgeTrim_Perpendicular, APIEdgeTrim_Horizontal, APIEdgeTrim_CustomAngle, APIEdgeTrim_AlignWithCut } API_EdgeTrimID;
Members
- APIEdgeTrim_Vertical
- Vertical edge.
- APIEdgeTrim_Perpendicular
- Perpendicular edge.
- APIEdgeTrim_Horizontal
- Horizontal edge.
- APIEdgeTrim_CustomAngle
- Custom angled edge trim.
The angle is defined in the API_EdgeTrim structure, which should be passed on or is returned in theedgeTrims
field of API_ElementMemo structure. - APIEdgeTrim_AlignWithCut
- Trim type of shell contour and hole contour edges (see API_ContourEdgeData). The trim is aligned along the extrusion of the cutting body.
Requirements
- Version: API 15 or later
- Header: APIdefs_Elements.h
See Also
API_EdgeTrim, API_ShellBaseType, API_ContourEdgeData
API_ElementMemo, API Types