Representation of a 3D edge.
typedef struct { API_3D_Head head; Int32 status; short filler_1; short color; Int32 vert1; Int32 vert2; Int32 pgon1; Int32 pgon2; } API_EdgeType;
Members
- head
- Header information of this component. This specifies the type and database index.
- status
- Information about the edge properties.
- color
- Refers to the color of the edge.
- vert1, vert2
- Vertex indices of the endpoints of the edge.
- pgon1, pgon2
- Indices of the neighboring polygons.
Remarks
Polygons are lists of edges with an orientation including the indices of the edges. One edge may belong to 0 to 2 polygons. Its indices are included in pgon1
, pgon2
. In case of side or single line the missing polygon signed with -1 index.
An edge has two endpoints, indexed by vert1
, vert2
.
Note that in the case of closed bodies, the polygon?s orientation is correct if the edge has different prefixes in the edge list of the two polygons.
Accessing edges are based on a body. First you must get a body by ACAPI_3D_GetComponent and just after is obtainable its components.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_3D.h
See Also
API_PedgType, API_PgonType, API_3D_Head, API_Component3D,
3D Manager, API Types