Possible element transformations.
typedef enum { APIEdit_Drag = 'DRAG', APIEdit_Rotate = 'ROTZ', APIEdit_Mirror = 'MIRR', APIEdit_Elevate = 'ELEV', APIEdit_Stretch = 'STRE', APIEdit_VertStretch = 'VSTR', APIEdit_Resize = 'RSIZ', APIEdit_General = 'GENE', APIEdit_PHeightStretch = 'PHST', APIEdit_PDirStretch = 'PDST' } API_EditCmdID;
Members
- APIEdit_Drag
- Drag or Drag a Copy operation
- APIEdit_Rotate
- Rotate or Rotate a Copy operation
- APIEdit_Mirror
- Mirror or Mirror a Copy operation
- APIEdit_Elevate
- Elevate operation
- APIEdit_Stretch
- Horizontal stretch
- APIEdit_VertStretch
- Vertical stretch
- APIEdit_Resize
- Resize operation
- APIEdit_General
- Other editing operation (e.g move a beam hole)
- APIEdit_PHeightStretch
- Special stretch of model elements (slanted beam or column) modifying the inclination angle with the height parameter fixed (preserved height stretch)
- APIEdit_PDirStretch
- Special stretch of model elements (slanted beam or column) in the direction of the element’s axis (preserved direction stretch)
Remarks
Refer to the API_EditPars structure for parametrization; or to the ACAPI_Element_Edit function to transform database elements.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h