Transformation parameters for elements.
typedef struct { API_EditCmdID typeID; bool withDelete; bool topNodeStretched; bool filler_1[2]; API_Coord origC; API_Coord3D begC; API_Coord3D endC; API_Coord3D endC2; double filler_2[8]; } API_EditPars;
Members
- typeID
- the operation code
- withDelete
- delete the target element after the operation (drag or drag a copy)
- topNodeStretched
- the upper node must be edited in case of vertical stretching
- origC
- the origo; used for mirror and rotate
- begC
- the start point of the edit vector; this is the reference point
- endC
- the end point of the edit vector; generally this is the second click in Archicad
- endC2
- additional vector end point; used for mirror
Remarks
Generally you have to think about the coordinates in the same way you should click in Archicad to perform the same operation. For example in case of rotation you have to set the origC
field to the origo, the begC
and endC
fields to the start and end points of the rotation angle.
The origo does not have vertical information, it just specifies the center of rotation. Other coordinates have a z component; its difference will specify the elevation factor; additive to the original operation.
This structure is used by the ACAPI_Element_Edit function.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_Edit, API_EditCmdID, API_Coord, API_Coord3D, API_Coord3D, API_Coord3D, API Types