API_​Elem_​Head

General element header for element types.

    typedef struct {
        API_ElemType                 type;
        UInt32                       filler_0;
        Int32                        filler_1;
        API_Guid                     guid;
        UInt64                       modiStamp;
        API_Guid                     groupGuid;
        API_Guid                     hotlinkGuid;
        short                        floorInd;
        API_AttributeIndex           layer;
        bool                         hasMemo;
        char                         drwIndex;
        short                        userId;
        short                        lockId;
        API_AttributeIndex           rgr_layer;
        API_RenovationStatusType     renovationStatus;
        API_Guid                     renovationFilterGuid;
    } API_Elem_Head;

 

Members

type
The type of the element.
guid Changed in API 11
The globally unique identifier of the element. It is type-independent, and guaranteed to be globally unique in all projects. (The only possible guid clash is between projects which have evolved from the same base project.) Also, it doesn’t change under any circumstances.
modiStamp Changed in API 12
The modification stamp of the element.
groupGuid Changed in API 12
The identifier of the group the element belongs to. APINULLGuid means the element is not grouped. Doesn’t apply to certain (non-groupable) element types.
hotlinkGuid Changed in API 12
The identifier of the hotlink instance the element belongs to (see API_HotlinkType). APINULLGuid means the element is not part of any hotlinks.
floorInd
The element belongs to this floor.
layer
The layer attribute index of the element.
hasMemo
Tells whether an element has extended information (memo) attached.
drwIndex
The index of the element in drawing order. It is important for bring to front/send to back type operations. Elements with higher drwIndex are drawn last.
userId
The member ID of the owner in TeamWork mode.
lockId
The member ID of the locker in TeamWork mode, bool in normal mode.
rgr_layer
Reference group layer (-1: special/locked group).
renovationStatus Featuring API 15
Renovation status of the element.
renovationFilterGuid Featuring API 15
Renovation filter GUID for the element. If set, the element’s visibility is determined by the given renovation filter. No special filter set when its value APIUndefinedGuid; APINULLGuid means that the renovation filter cannot be determined at the time of the query.

 

Remarks

Changed in API 12  From version 12 the element refers to the containing group by the Guid of the group element. The m_groupId field has been eliminated, the top level group can be obtained with the APIAny_GetMainGroupGuidID goody function.

Changed in API 18  From version 18 the index-based identification is not available any more; please use GUIDs.

Changed in API 26  From version 26 the typeID and variationID members were merged into an API_ElemType structure.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Element, API_AttributeIndex,
Element Manager, API Types