API_​ElemCategoryID

Type identifiers of element category types.

    typedef enum {
        API_ElemCategory_Undefined             = 0,
        API_ElemCategory_StructuralFunction,
        API_ElemCategory_Position,
        API_ElemCategory_RenovationStatus,
        API_ElemCategory_RenovationFilter,
        API_ElemCategory_BRI
    } API_ElemCategoryID;

 

Members

API_ElemCategory_Undefined
(Undefined category)
API_ElemCategory_StructuralFunction
Structural Function category
API_ElemCategory_Position
Position category
API_ElemCategory_RenovationStatus
Renovation status category
API_ElemCategory_RenovationFilter
Renovation filter category
API_ElemCategory_BRI
(available only in GER localized version)

 

Remarks

API_ElemCategoryID is used in element category (API_ElemCategory structure) as identifier.

 

Requirements

Version: API 19 or later
Header: APIdefs_Elements.h

 

See Also

API_ElemCategory
API Types