Element category value structure.
typedef struct { API_Guid guid; API_ElemCategory category; GS::uchar_t name [API_UniLongNameLen]; bool isVisibleOnUI; bool usableAsCriteria; bool filler_1[3]; } API_ElemCategoryValue;
Members
- guid
- GUID of the category value
- category
- the category of the category value
- name
- localized name of the category value
- isVisibleOnUI
- specifies if it is visible on the UI
- usableAsCriteria
- specifies if it is usable as a criteria
Remarks
This structure contains the data of an element category value. For available categories check API_ElemCategoryID.
Requirements
- Version: API 19 or later
- Header: APIdefs_Elements.h
See Also
API_ElemCategory, API_Guid, GS::UniString