API_​ElemDifference

Common structure for the element difference generator components.

    typedef struct {
        GS::HashSetAPI_Guid>>            newElements;
        GS::HashSetAPI_Guid>>            modifiedElements;
        GS::HashSetAPI_Guid>>            deletedElements;
        bool                        	  isEnvironmentChanged Featuring API 26;
    } API_ElemDifference;

 

Members

newElements
The new elements.
modifiedElements
The modified elements.
deletedElements
The deleted elements.
isEnvironmentChanged API 26 feature
True if any of the following is changed: the view or the settings of the view, project information or preferences, property definitions, geographical locations.

 

Remarks

This structure specify element difference for the Element difference generator.

You can get a elmenet difference by the ACAPI_ElemDifferenceGenerator_GenerateDifference function.

 

Requirements

Version: API 23 or later
Header: APIdefs_ElementDifferenceGenerator.h

 

See Also

ACAPI_ElemDifferenceGenerator_GenerateDifference,
API Types