Common structure for the element difference generator components.
typedef struct { API_ElemDifferenceGeneratorStateType stateType; GSHandle stateHdl; IO::Location fileLocation; API_Guid viewGuid; } API_ElemDifferenceGeneratorState;
Members
- stateType
- The type of the difference generator state.
- stateHdl
- The effective state of the difference generator, if the stateType is APIDiffState_InMemory.
- fileLocation
- The path of the file, that will be use if the stateType is APIDiffState_InFile.
- viewGuid
- The view guid, that will assure that the difference come from used element change not from the view settings, used only in APIDiff_ContextBased generator.
Remarks
This structure specify the difference generator state.
You can get a elemenet state by the ACAPI_ElemDifferenceGenerator_GetState function, and use in ACAPI_ElemDifferenceGenerator_GenerateDifference function.
Requirements
- Version: API 23 or later
- Header: APIdefs_ElementDifferenceGenerator.h
See Also
ACAPI_ElemDifferenceGenerator_GenerateDifference, ACAPI_ElemDifferenceGenerator_GetState,
API Types