API_​ElemDifferenceGeneratorTypeID

Determines the type of the element difference generator methode type.

    typedef enum {
        APIDiff_ModificationStampBased,
        APIDiff_3DModelBased,
        APIDiff_ContextBased,
    } API_ElemDifferenceGeneratorTypeID;

 

Members

APIDiff_ModificationStampBased
Modifcation stamp based difference generator, the old ACAPI_ProjectCompare, operate only with file.
APIDiff_3DModelBased
3D model base difference generator, the old ACAPI_ModelComapre.
APIDiff_ContextBased
Project context based, give an difference take account of the connection between the elements.

 

Requirements

Version: API 23 or later
Header: APIdefs_ElementDifferenceGenerator.h

 

See Also

ACAPI_ElemDifferenceGenerator_GenerateDifference, ACAPI_ElemDifferenceGenerator_GetState,
API Types