Floor plan display options of construction elements.
typedef enum { API_Standard, API_StandardWithAbstract, API_CutOnly, API_OutLinesOnly, API_AbstractAll, API_CutAll } API_ElemDisplayOptionsID;
Members
- API_Standard
- Shows cut part of element, plus its uncut (downward) part in 3D-like form
(‘Projected’ in the Settings dialog popups) - API_StandardWithAbstract
- Shows cut part of element (e.g., as cut at the level of the Floor Plan Cut Plane), plus the element’s overhead part (i.e. the part of the element that is above the Floor Plan Cut Plane
(‘Projected with Overhead’ in the Settings dialog popups) - API_CutOnly
- Displays only the cut part of element, as cut with the Floor Plan Cut Plane (symbolic representation, which means 2D full view in case of Door/Window)
(‘Cut Only’ in the Settings dialog popups) - API_OutLinesOnly
- The entire element’s outline is shown using its uncut attributes (not available for Door/Window)
(‘Outlines Only’ in the Settings dialog popups) - API_AbstractAll
- The entire element’s outline is shown using its overhead attributes
(‘Overhead All’ in the Settings dialog popups) - API_CutAll
- The whole floor plan projection of simple walls or vertical (simple or complex) columns will be displayed as cut, using their cut line and cut fill attributes, regardless of the elements’ vertical position. This option is available only for simple straight walls or columns, or for complex columns, and only if the Show on Story control is set to “Current/Own Story only”. The Floor Plan Cut plane settings do not affect the display of these elements.
(‘Symbolic Cut’ in the Settings dialog popups)
Remarks
Element display option defines how a construction element appears on the floor plan.
Requirements
- Version: API 10 or later
- Header: APIdefs_Elements.h
See Also
API_BeamType, API_ColumnType, API_RoofType, API_WallType, API_WindowType
API_FloorPlanCutDefinition, API_StoryVisibility
API TypesAPI_ElemProjectionModesID