API_​Element

A union collecting all known element types.

    typedef union {
        API_Elem_Head                     header;
        API_WallType                      wall;
        API_ColumnType                    column;
        API_BeamType                      beam;
        API_WindowType                    window;
        API_DoorType                      door;
        API_ObjectType                    object;
        API_LampType                      lamp;
        API_SlabType                      slab;
        API_RoofType                      roof;
        API_MeshType                      mesh;
        API_DimensionType                 dimension;
        API_RadialDimensionType           radialDimension;
        API_LevelDimensionType            levelDimension;
        API_AngleDimensionType            angleDimension;
        API_TextType                      text;
        API_LabelType                     label;
        API_ZoneType                      zone;
        API_HatchType                     hatch;
        API_LineType                      line;
        API_PolyLineType                  polyLine;
        API_ArcType                       arc;
        API_CircleType                    circle;
        API_SplineType                    spline;
        API_HotspotType                   hotspot;
        API_PictureType                   picture;
        API_CutPlaneType                  cutPlane;
        API_ElevationType                 elevation;
        API_InteriorElevationType         interiorElevation;
        API_CameraType                    camera;
        API_CamSetType                    camset;
        API_DrawingType                   drawing;
        API_SectElemType                  sectElem;
        API_DetailType                    detail;
        API_WorksheetType                 worksheet;
        API_HotlinkType                   hotlink;
        API_CurtainWallType               curtainWall;
        API_CWSegmentType                 cwSegment;
        API_CWFrameType                   cwFrame;
        API_CWPanelType                   cwPanel;
        API_CWJunctionType                cwJunction;
        API_CWAccessoryType               cwAccessory;
        API_ShellType                     shell;
        API_MorphType                     morph;
        API_SkylightType                  skylight;
        API_ChangeMarkerType              changeMarker;
        API_StairType                     stair;
        API_StairRiserType                stairRiser;
        API_StairTreadType                stairTread;
        API_StairStructureType            stairStructure;
        API_RailingType                   railing;
        API_RailingToprailType            railingToprail;
        API_RailingHandrailType           railingHandrail;
        API_RailingRailType               railingRail;
        API_RailingRailEndType            railingToprailEnd;
        API_RailingRailEndType            railingHandrailEnd;
        API_RailingRailEndType            railingRailEnd;
        API_RailingFinishType             railingEndFinish;
        API_RailingRailConnectionType     railingToprailConnection;
        API_RailingRailConnectionType     railingHandrailConnection;
        API_RailingRailConnectionType     railingRailConnection;
        API_RailingPostType               railingPost;
        API_RailingInnerPostType          railingInnerPost;
        API_RailingBalusterSetType        railingBalusterSet;
        API_RailingBalusterType           railingBaluster;
        API_RailingPanelType              railingPanel;
        API_RailingNodeType               railingNode;
        API_RailingSegmentType            railingSegment;
        API_RailingPatternType            railingPattern;
        API_ColumnSegmentType             columnSegment;
        API_BeamSegmentType               beamSegment;
        API_ExternalElemType              externalElem
    } API_Element;

 

Members

header
General element header.
wall
Represents a wall.
column
Represents a column.
beam
Represents a beam.
window
Represents a window.
door
Represents a door.
object
Represents an object.
lamp
Represents a lamp.
slab
Represents a slab.
roof
Represents a roof.
mesh
Represents a mesh.
dimension
Represents a dimension.
radialDimension
Represents a radial dimension.
levelDimension
Represents a level dimension.
angleDimension
Represents an angle dimension.
text
Represents a text.
label
Represents a label.
zone
Represents a zone.
hatch
Represents a hatch.
line
Represents a 2D line.
polyLine
Represents a 2D polyline.
arc
Represents a 2D arc.
circle
Represents a 2D circle.
spline
Represents a 2D spline.
hotspot
Represents a hotspot.
picture
Represents a picture.
cutPlane
Represents a section.
elevation 11
Represents an elevation.
interiorElevation 11
Represents an interior elevation.
camera
Represents a camera.
camset
Represents a camera set.
drawing
Represents a drawing element.
sectElem
Represents an element in the section window.
detail
Represents a detail drawing.
hotlink Changed in API 12
Represents a hotlink.
worksheet 11
Represents a worksheet.
curtainWall Changed in API 12
Represents a curtain wall.
cwSegment Changed in API 12
Represents a curtain wall segment.
cwFrame Changed in API 12
Represents a curtain wall frame.
cwPanel Changed in API 12
Represents a curtain wall panel.
cwJunction Changed in API 12
Represents a curtain wall junction.
cwAccessory Changed in API 12
Represents a curtain wall accessory.
shell Changed in API 15
Represents a shell (kind of a roof with special geometry).
skylight Changed in API 15
Represents a skylight (a window put into roofs and shells).
morph Changed in API 16
Represents a morph.
changeMarker Changed in API 18
Represents a ChangeMarker.
stair Changed in API 21
Represents a Stair.
stairRiser Changed in API 21
Represents a Riser.
stairTread Changed in API 21
Represents a Tread.
stairStructure Changed in API 21
Represents a Stair structure.
railing New in API 21
Represents a Railing structure.
railingToprail New in API 21
Represents a Toprail structure.
railingHandrail New in API 21
Represents a Handrail structure.
railingRail New in API 21
Represents a Rail structure.
railingToprailEnd New in API 21
Represents a Toprail End structure.
railingHandrailEnd New in API 21
Represents a Handrail End structure.
railingRailEnd New in API 21
Represents a Rail End structure.
railingToprailConnection New in API 21
Represents a Toprail Connection structure.
railingHandrailConnection New in API 21
Represents a Handrail Connection structure.
railingRailConnection New in API 21
Represents a Rail Connection structure.
railingPost New in API 21
Represents a Railing Post structure.
railingInnerPost New in API 21
Represents an Inner Post structure.
railingBalusterSet New in API 21
Represents a Baluster Set structure.
railingBaluster New in API 21
Represents a Baluster structure.
railingPanel New in API 21
Represents a Railing Panel structure.
railingNode New in API 21
Represents a Railing Node structure.
railingSegment New in API 21
Represents a Railing Segment structure.
railingPattern New in API 21
Represents a Railing Pattern structure.
columnSegment New in API 23
Represents a Column segment structure.
beamSegment New in API 23
Represents a Beam segment structure.
externalElem New in API 26
Represents an external element. See remarks for more information.

 

Remarks

Database items named elements are global collections of constuction and drawing elements which are placed onto the floorplan, Section/Elevation etc. windows.

API functions operating on the element databases begin with the ACAPI_Element_ prefix, refer to the Element Manager for more details.

Many element related functions use the API_Element structure on the parameter list. As a general rule, you have to fill the required fields in the union, then the server application parses the request based on the values and passes the return parameters in the same parameter. This is why most of the functions do not have the const directive in the prototypes.

Refer to the Save data into the Element records document to get information how to save/assign custom data to the element records and save it into the project file for later use.

New in API 26 In version 26 the Analytical element types were replaced by the externalElem member. The former structures (e.g. API_AnalyticalLinkType) can be obtained by the appropriate functions (e.g. ACAPI_AnalyticalModel_GetLinkFromElement).

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head,
API_WallType, API_ColumnType, API_BeamType, API_WindowType, API_DoorType, API_ObjectType, API_LampType, API_SlabType, API_RoofType, API_MeshType, API_DimensionType, API_RadialDimensionType, API_LevelDimensionType, API_AngleDimensionType, API_TextType, API_LabelType, API_ZoneType, API_HatchType, API_LineType, API_PolyLineType, API_ArcType, API_CircleType, API_SplineType, API_HotspotType, API_PictureType, API_CutPlaneType, API_ElevationType, API_InteriorElevationType, API_CameraType, API_CamSetType, API_DrawingType, API_SectElemType, API_ChangeMarkerType, API_DetailType, API_WorksheetType, API_HotlinkType, API_CurtainWallType, API_CWSegmentType, API_CWFrameType, API_CWPanelType, API_CWJunctionType, API_CWAccessoryType, API_ShellType, API_SkylightType, API_MorphType, API_StairType, API_RailingType, API_ColumnSegmentType, API_BeamSegmentType
Element Manager, API Types